[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

configure and gcc

From: david
Subject: configure and gcc
Date: Sat, 04 Nov 2006 18:52:39 -0700
User-agent: Internet Messaging Program (IMP) H3 (4.1.1)


I am trying to incorporate configure into a hc12 library rework of libgel. In the original by Stephane Carre, he didn't use autoconf. I want to try and configure GCC version (m6812-elf-gcc) instead of gcc. I tried using AC_PROG_CC() but it doesn't like my other variables and runs all over my config. So I tried to use AC_VAR_ARG

I tried this and it gave me errors on automake --force

Here is my snippet

AC_ARG_VAR([TARGET_CPP],[target cpp program])
AC_ARG_VAR([TARGET_GCC],[target gcc program])
{this sets target_alias properly and TARGET_GCC}
and then inside my  I used this


If I leave out src/Makefile from AC_CONFIG_FILES([]) I get no error.

but when I add in src/Makefile and then I tried to autoreconf -fvi I get this error:
$ autoreconf -fvi
autoreconf: Entering directory `.'
autoreconf: not using Gettext
autoreconf: running: aclocal --force
autoreconf: tracing
autoreconf: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
autoreconf: running: /usr/bin/autoheader --force
autoreconf: running: automake-1.9 --add-missing --copy --force-missing
/usr/share/automake-1.9/am/ am__fastdepCC does not appear in AM_CONDITIONAL
/usr/share/automake-1.9/am/ AMDEP does not appear in AM_CONDITIONAL
autoreconf: automake-1.9 failed with exit status: 1
address@hidden libhc12]$

So what causes this error and what am I not getting about configuring gcc?

I am using Fedora Core 6 Linux with the following RPMs:

Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
autoconf.noarch                          2.59-12                installed
autogen.i386                             5.8.7-3.fc6            installed
automake.noarch                          1.9.6-2.1              installed
automake14.noarch                        1.4p6-13               installed
automake15.noarch                        1.5-16                 installed
automake16.noarch                        1.6.3-8                installed
automake17.noarch                        1.7.9-7                installed
libtool.i386                             1.5.22-6.1             installed

I don't think this is a version or tool issue, because I can get my autotools to work on other projects.

Thank you in advance!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]