[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] avr-gcc-list Digest, Vol 6, Issue 11

From: Dafni & Robert Berger
Subject: [avr-gcc-list] avr-gcc-list Digest, Vol 6, Issue 11
Date: Sun, 13 Jul 2003 14:33:37 +0300

        --> Robert
Hi Joerg,

        My test was the following:
I created an elf file and with avr-objcopy, objtool and and elfcoff the coff

Only with elfcoff it's executing properly (with some not so trivial code).

I'll try to come up with an example to show what's going on.

This will take some time, since I would like to have a single file, which
shows the problem and not, as I have it now, many files and modules.
<-- Robert

"Dafni & Robert Berger" <address@hidden> wrote:

> If took me a couple of weeks to figure out, that the latest WinAVR
> (also with beta patches) corrupts your code in the elf to coff
> conversion.

Well, you know that the COFF conversion is currently marked `beta'.
So if you feel that something corrupts your code (which IMHO cannot
even happen since the conversion only touches the debugging symbols
but not the code itself), i'd like to hear the details from you, so
it can eventually be fixed.

Date: Fri, 11 Jul 2003 11:00:42 +0200
From: Iztok Zupet <address@hidden>

 Sorry, but this happened also to me, bout only when working with a program
full of interrupts. When programmed with uisp, it worked fine and programmed
with AvrStudio via hex file it also worked. But when I converted it to coff
file (both via objcopy or elfcoff) and downloaded via JTAG with AvrStudio,
both serial interrupt routines stopped working, like if the vectors werent
set up right.

--> Robert
        My program is not full of interrupts; it just uses the timer interrupt
        <-- Robert

reply via email to

[Prev in Thread] Current Thread [Next in Thread]