[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] Debugging assembly with ELF format and AVRStudio

From: Jeff Kowing
Subject: [avr-gcc-list] Debugging assembly with ELF format and AVRStudio
Date: Wed, 11 May 2005 14:39:06 -0500

Hi most excellent and appreciated AVR gurus,

Apologies first, I have tried to follow the conversations in the list
about debugging assembly and the ELF/dwarf-2 difficulties.  I am using
the WinAVR20050214 tools (and also similar versioned tools on Linux) in
conjunction with AVRStudio 4.11 (Service Pack 2)  I just want to be sure
I understand correctly, and am not doing something stupid.

I find that I can debug an assembly program compiled into ELF format
with gdb and simulavr when using the avr-as debug flag: -gstabs

This same ELF program will not load into AVRStudio.  It gives me the
error: Coordinator An error occured while reading the object file. The
file may be of wrong type or corrupted, or the object file reader is not
up to date.

In fact, I could find NO combination of debug flags (including no debug
flags at all!) that would allow me to load the ELF file.  Please note,
everything works fine when compiling a C source file, just not with an
assembler program.

So, am I correct that currently it is not possible to load/debug an
assembly program with AVRStudio that is compiled into ELF format?

I guess I should also add that I tried using -gdwarf and/or -gdwarf2 as
the debug flags for avr-as but apparently dwarf debugging information is
not generated as that did not work even for the gdb/simulavr

Jeff Kowing

reply via email to

[Prev in Thread] Current Thread [Next in Thread]