[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes

From: Wojtek Kaniewski
Subject: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes
Date: Thu, 08 Sep 2005 10:45:02 +0200
User-agent: Mozilla Thunderbird 1.0.6 (X11/20050716)

E. Weddington wrote:
- I think it would be best to go ahead and deprecate timer_enable_int() and enable_external_int(). I agree that the naming wasn't very well thought out, perhaps.

If naming consistency is important, then we should probably do something about fdevopen() and fdev_*() too. All fdev functions except fdevopen() use underscores.

- Going along with the theme, it would be good to eventually have an <avr/timer.h> header that deals with timers. Again, I have some possible candidates as a starting point.

Is this header along with <avr/extint.h> available somewhere? I'd like to take a look at it.

- I think your idea of <avr/deprecated.h> is a great idea! We could put all of those outdated macros in it: sbi(), cbi(), outp(), inp(), etc. ad naseum. :-)

That would be great. I wouldn't have to explain my friends what does "PORTD&=~_BV(4);" mean (-;

- Our previous offline discussion of having a <util/*> tree would be good for "utility headers", i.e. headers that are nice, but not necessary, and that is not related to the AVR hardware. The first entry in this would be <util/bit.h> for bit manipulation macros that we have discussed.

Is there any policy for supporting some additional hardware? It would be nice if users got support for things like HD44780-compatible displays or 1-Wire bus from the avr-libc, so they wouldn't need to reinvent the wheel or deal with non-BSD licenses.

BTW, <util/...> would be a good place for <avr/crc16.h> too.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]