[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] avr-gcc build errors

From: Neil Davey
Subject: Re: [avr-gcc-list] avr-gcc build errors
Date: Fri, 28 Mar 2008 01:26:57 +1000
User-agent: Thunderbird (Windows/20080213)

Hi Mark,
I had similar problems when I first tried to compile gcc... (same error
message also..)

I then followed the procedure detailed here: (pointed out to me by someone on the list)

using the latest versions, built without any problems after that...

Neil Davey

address@hidden wrote:
Hello, I am trying to build the AVR-GCC tool chain using binutils-2.18,
gcc-core-4.3.0 & avr-libc-1.6-20080228. Following the installation
instructions in avr-libc Reference Manual 1.4.5, I have successfully
installed binutils. Then I unpack gcc-core & run ../configure
--prefix=/usr/local/avr --target=avr --enable-languages=c --disable-nls
--disable-libssp --with-dwarf2. This runs with no problem. Problems
occur when I run make. My error output is:

checking for suffix of object files... configure: error: cannot compute
suffix of object files: cannot compile
See `config.log' for more details.
make[1]: *** [configure-target-libgcc] Error 1
make[1]: Leaving directory `/home/mark/gcc-4.3.0'
make: *** [all] Error 2

I have also tried gcc-core-4.2.3 which also gives errors on make
although different. My PATH includes /usr/local/avr/bin & I have
configured & built the tools in a separate subdirectory as recommended.
I am running Ubuntu 6.06 & 7.04. My current development tools are on
Ubuntu 6.06. I have also installed libgmp, libmpfr, flex, bison & byacc
in the hope that it may resolve the problem, but no luck.

I want to do a development with the AT90USB1287 & my current tools don't
support this device. I am assuming that building with these latest tools
will enable support for this processor. I would appreciate any help.
Thanks, Mark

AVR-GCC-list mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]