[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] Toolchain not showing up with xmega support

From: David L. Martin
Subject: Re: [avr-gcc-list] Toolchain not showing up with xmega support
Date: Mon, 20 Jun 2011 14:10:38 -0400
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110424 Lightning/1.0b2 Thunderbird/3.1.10

On 06/20/2011 01:40 PM, David L. Martin wrote:
On 06/20/2011 01:17 PM, Weddington, Eric wrote:
-----Original Message-----
From: David L. Martin [mailto:address@hidden
Sent: Monday, June 20, 2011 10:56 AM
To: Weddington, Eric
Cc: address@hidden
Subject: Re: [avr-gcc-list] Toolchain not showing up with xmega support

Yeah I have since figured out, the patches are my problem.  I installed

I guess I should start from the beginning.

I need a toolchain that supports the atxmega128a1, what method would you

I just downloaded the one from the atmel website, I'm gonna try that,
but I don't have a lot of confidence in it.
Hmm. Why do you not have confidence in the patch from Atmel?

You're generally on the right path. Again, what versions of binutils, gcc are you building?

Atmel just seems to run hot/cold with the Linux support, that lowers my confidence.

I tried 4.5.3 on gcc, and 2.21.52 on binutils. Both compiled/installed/worked easily, just sketchy xmega support.

When I tried to find patches to get the xmega support into both of those, I became completely lost.

Hence my current attempt to get the atmel toolchain working (just about to try it).

Tried the Atmel tool toolchain, ran into a lot of compile errors. Missing defines, etc.
Not even Atmel's own code examples compile using their supplied toolchain.

For example their ebi_driver won't compile, stuff missing like EBI_CS_ASPACE_t. Might just be name changes.

Damn, I didn't expect this to be such a bear.

How does everyone else get a toolchain up and running for the xmega? Should I switch back to the buggy debian packages?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]