[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PostScript fonts path search broken in configure

From: David Starks-Browning
Subject: PostScript fonts path search broken in configure
Date: Thu, 15 Feb 2001 16:43:08 +0000


This is a2ps-4.13b.tar.gz dated 8 Mar 2000 from

This bit of configure code that looks for PostScript fonts paths is

> echo $ECHO_N "checking for PostScript fonts path... $ECHO_C" 1>&6
> echo "configure:8448: checking for PostScript fonts path" 1>&5
> # Try to find some PostScript fonts.
> # Find out if ghostscript is installed
> ac_psfont_path=
> for ac_dir in /usr/local/ghostscript/fonts \
>   /usr/local/share/ghostscript/fonts;
> do
>   if test "cd $ac_dir 2>/dev/null && echo *.afm"; then
>     ac_psfont_path="$ac_psfont_path:$ac_dir";
>   fi
> done
> if test -n "$ac_psfont_path"; then
>   PSFONT_PATH=`echo "$ac_psfont_path" | sed -e 's/^://'`
> fi

Specifically, this test:

>   if test "cd $ac_dir 2>/dev/null && echo *.afm"; then

is successful even if $ac_dir does not exist.  I've tried some
variations on how this quoted, which get the correct answer on Linux
and IRIX, but crash configure on Compaq and Solaris.  Even if that
worked, there is no provision to find anything other than
/usr/local/ghostscript/fonts or /usr/local/share/ghostscript/fonts,
which is not very useful.  (Ours happen to be in
${prefix}/share/ghostscript/fonts, for example, and ${prefix} is not

Before I look harder at this, perhaps you could tell me how the
PSFONT_PATH is used, and whether it's worth getting right.


  David Starks-Browning                  | address@hidden
  EMBL Outstation --                     |
  The European Bioinformatics Institute  |
  Wellcome Trust Genome Campus           | tel: +44 (1223) 494 616
  Hinxton, Cambridge, CB10 1SD, UK       | fax: +44 (1223) 494 468

reply via email to

[Prev in Thread] Current Thread [Next in Thread]