[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] Re: rel-0-9-1; installation problem

From: David Kastrup
Subject: [Bug-AUCTeX] Re: rel-0-9-1; installation problem
Date: Fri, 08 Apr 2005 23:41:34 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Jeff Flowers <address@hidden> writes:

> David Kastrup wrote:
>> [Keeping bug-auctex copied]
>>>>>>>The command line was
>>>>>>>$ ./configure --prefix=d:\\emacs --with-texmf-dir=c:\\texmf
> [snip]
>> The rest looks sane.  I'll append a patch that is supposed to deal
>> with everything.  You have to run patch -p0 with an input
>> redirection from this mail (or just the patch section) in the
>> preview directory, then run autoconf, and restart ./configure with
>> the above options.  Let us see whether you fare better this time.
>> The packagelispdir stuff I can't deal with sensibly right now since
>> I am working on replacing it with something saner, and since it
>> worked before, there is not much to be gained by getting the old
>> stuff to work in exceptional circumstances.  However, this did the
>> right thing with other test scenarios, so it might just work.
> Thanks again
> your patch worked! I did the above. This time I had to use the invocation
> $ ./configure --prefix=d:\\emacs --with-texmf-dir=c:\\texmf
> -with-lispdir=d:\\emacs\\site-lisp
> to avoid the error message
> checking where lisp files go... configure: error: Cannot locate lisp
> directory, use  --with-lispdir, --datadir, or possibly --prefix to
> rectify this

Well, I changed a number of other things right now, so it might be
that this problem is gone as well, but since this has changed
installation instructions somewhat as well as Makefile.in, aclocal.m4
and configure.in, it appears to be a bit large for a patch.

If it is ok with you, I'll send you the complete files in Email so
that you may test whether the above problem also disappears.

The behavior you see now is much less severe than previously: if
installation fails with a good error message and instructions what to
do, this is not really release-critical, but still I'd like to have
this checked before the next release if possible.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]