[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-AUCTeX] 11.86; auctex does not work properly if TeX-engine is s

From: Carlos Russo
Subject: Re: [Bug-AUCTeX] 11.86; auctex does not work properly if TeX-engine is set to luatex
Date: Mon, 28 Feb 2011 16:41:41 +0000

Hi again,

I think the problem is the fact that LaTeX and lualatex behave differently to 
the same command line.

If  I look at the output of  lualatex, I get:

Running `LaTeX' on `test' with ``lualatex --synctex=1 -interaction=nonstopmode 
"\input" test.tex''
This is LuaTeX, Version beta-0.60.2-2010071217 (TeX Live 2010) (rev 3736) 
 restricted \write18 enabled.
LaTeX2e <2009/09/24>
LuaTeX adaptation of babel <v3.8l-luatex-1.4> and hyphenation patterns for 
english, dumylang, nohyphenation, loaded.
(./test.tex (/usr/local/texlive/2010/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(./texput.aux) )
 264 words of node memory still in use:
   2 hlist, 1 vlist, 1 rule, 2 glue, 40 glue_spec, 1 write nodes
   avail lists: 2:12,3:5,4:40,5:3,6:64,7:2,9:7,10:5
Output written on texput.pdf (1 page, 23624 bytes).
SyncTeX written on texput.synctex.gz
Transcript written on texput.log.

LaTeX finished at Mon Feb 28 16:37:05

It turns out the problem here is the "\input" part!
If I go to the command line and type
lualatex --synctex=1 -interaction=nonstopmode test.tex'

the file test.pdf is produced, as expected, whereas if I include the "\input" 
part, the texput.pdf file is produced instead.

How can I  fix this?
I suppose I need to put something on my .emacs, but I have no clue what.... 
help! :)


On Feb 28, 2011, at 11:42 , Carlos Russo wrote:

> Hi
> As I said, I'm using Aquamacs 2.1.
> Here's how I can reproduce the bug:
> Step 1: Open Aquamacs by calling it from the command line
> /Applications/Aquamacs.app/Contents/MacOS/Aquamacs -Q -l auctex
> Step 2: C-x C-f to open the attached file test.tex 
> Step 3 (optional): Go to menu "Command"->"TeXing options", enable "Generate 
> PDF"
> Step 3: Press C-c C-c. Aquamacs offers to compile, I press Return and a 
> test.pdf  is produced.
> Step 4: Press C-c C-c again. Emacs offers to view the file. It contains the 
> text "This file was compiled using LaTeX"
> Step 4: Go to menu "Command"->"TeXing options" and select "Use LuaTeX engine"
> Step 5: delete all files except for test.tex
> Step 6: Press C-c C-c, Aquamacs offers to compile, I press Return and the 
> files texput.{aux,log,pdf}  are produced. I was expecting test.{aux,log,pdf} 
> files
> Step 7: Press C-c C-c, Aquamacs offers to compile, instead of offering to 
> view the pdf file. I suppose this happens because there is no test.pdf 
> file,i.e, the filename is wrong.
> If I open the file texput.pdf, I get the desired output. There seems to be 
> some problem while handling the input options of lualatex.
> If I run lualatex --version I get:
> This is LuaTeX, Version beta-0.60.2-2010071217 (TeX Live 2010) (rev 3736)
> I confirm that this also happens while using auctex 11.86 and:
> * Aquamacs nightly (3.x dev);
> * Mac OSX 10.6 built-in version of GNU Emacs (22.1.1).
> Moreover, I installed the CVS version of auctex with GNU Emacs (22.1.1)'s.
> The texput.* files are still being produced while using LuaTeX
> Could this be a LuaTeX issue rather than AUCTEX's ?
> Cheers,
> Carlos
> On Feb 27, 2011, at 15:53 , Ralf Angeli wrote:
>> * Carlos Russo (2011-02-25) writes:
>>> Imagine that I am editing a file "test.tex" and it is a valid lualatex
>>> file.  If I run customize the variable TeX-Engine by setting it to
>>> LuaTeX, I'm expecting that lualatex is called whenever I press C-c C-c
>>> and choose "LaTeX".  Indeed lualatex runs and compiles the file, but
>>> the files that are produced are called "texput.aux", "texput.pdf" and
>>> "texput.synctex.gz" rather than "test.*".
>> I cannot reproduce this here.  (I'm using the development version of
>> AUCTeX but I doubt this makes a difference because there haven't been
>> changes to the engine handling since the last release.)  Please provide
>> a step-by-step description for reproducing the problem, starting with
>> `emacs -Q -l auctex'.  The testcase should ideally also include a sample
>> file.
>> -- 
>> Ralf

Attachment: smime.p7s
Description: S/MIME cryptographic signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]