bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: IFS=$'\xb2'


From: Chris F.A. Johnson
Subject: Re: IFS=$'\xb2'
Date: Sat, 6 Aug 2005 10:00:07 -0400 (EDT)

On Fri, 5 Aug 2005, Xavier Kerestesy wrote:

Date: Fri, 05 Aug 2005 11:37:59 -0700
From: Xavier Kerestesy <address@hidden>
To: address@hidden
Subject: IFS=$'\xb2'

Good day, we have tried the following command "IFS='?';" (ascii translated "0xb2") on 3 systems, Fedora, Ubuntu, and RH AS3. The code causes Seg Faults on Fedora and Ubuntu, but seems to works on RH AS3. We also tried "IFS=$'\xb2' ;" with the same results.

The only thing I can see is that RH3 uses Bash 2.05 while Fedora and Ubuntu use Bash 3.0. I have uploaded the commands in a script to make it easier. http://www.mainstreamgaming.com/ciscocmd.tgz. This issue is easy to reproduce, as I had several people in irc trying to help me. This apparently is a seperator sequence from Cisco routers.

     I cannot reproduce this bug in 3.00.16(1)-release. I am using
     Mandrive LE2005, but I compiled my own bash.

--
    Chris F.A. Johnson                     <http://cfaj.freeshell.org>
    ==================================================================
    Shell Scripting Recipes: A Problem-Solution Approach, 2005, Apress
    <http://www.torfree.net/~chris/books/cfaj/ssr.html>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]