[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Calling Bash with /S

From: Roman Rakus
Subject: Re: Calling Bash with /S
Date: Thu, 23 Jun 2011 11:57:27 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110307 Fedora/3.1.9-0.39.b3pre.fc14 Lightning/1.0b3pre Thunderbird/3.1.9

On 06/22/2011 06:59 PM, sweinberger wrote:
Hi All,

I am calling bash from dmake.  The make file initiates the call to bash as

/bin/bash /S /c ""
/bin/bash -S -c ?
Anyway, -S is not valid option in Fedora's bash version 4.1.7.
The command to execute is between the double quotes.  For instance

In Make File:
@ls -l ./SomeDir/*

Bash Command
/bin/bash /S /c "ls -l ./SomeDir/*"

The /S from what I see enables regular expression processing in the bash
command line, but maybe I might be wrong.  In any event, the problem that I
have is the asterisk.  Bash does not like it.  I tried escaping it with a
backslash up to nine levels but that did not work; should only require one.
Pathname expansion is on by default. Can be turned off by `set -f' or invoking bash with `-f' option.
Yes, the actual command that I use is not ls.  In the real example, I am
using "rm -f", but ls is a good example too and safer for experimentation.

How do I write the command line, so that it works?  "ls -l ./SomeDir/\*"
does not work, nor anything else that I tried so far.
Explain what means `does not work'. What it does?
Thanks in advance,



reply via email to

[Prev in Thread] Current Thread [Next in Thread]