[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "-flto -O2" shouln't opt out "undefined reference" error

From: Jim Wilson
Subject: Re: "-flto -O2" shouln't opt out "undefined reference" error
Date: Fri, 20 Jan 2017 16:43:47 -0800

On Tue, Jan 17, 2017 at 7:27 PM, Xuefer <address@hidden> wrote:
> volatile: i tried already with clang/llvm it worked.
> i'm using gentoo linux, trying to emerge everything with -flto. i'm not sure
> if i understand linker/compiler bug or not a bug, i wonder how many script
> is affected by this issue.

OK, if you want everything compiled with -flto then you may need to
fix some package configure scripts to make this work, and you may need
autoconf fixes too.  This may not be well tested.

Exactly how lto integrates into a package build system may vary from
package to package.  For GCC, you can do
--with-build-config=bootstrap-lto and it will bootstrap itself with
LTO enabled.  For most other packages though putting -flto in CFLAGS
before configure/make is probably good enough.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]