[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug report for bison 1.33

From: Akim Demaille
Subject: Re: Bug report for bison 1.33
Date: Tue, 12 Feb 2002 18:20:20 +0100
User-agent: Gnus/5.090006 (Oort Gnus v0.06) XEmacs/21.4 (Common Lisp, i386-debian-linux)

| Dear bison maintainers

Dear User :)

| I run a MacOS X (10.1.2) with installed kernel, not modified by me.
| The compiler used its the one that comes with the system, the headers
| have not been touched.  Everything should be vanilla.
| I ran ./configure as follows:
| env INSTALL='/usr/bin/install -c -p' CFLAGS='-O2 -Os -pipe'
| LDFLAGS='-O2 -Os' ./configure --with-included-gettext
| Bison itself does not build out of the generated Makefile, so I had to
| copy and paste the following line, so as to get an executable:
| cd src
| gcc -O2 -Os -o bison *.o ../intl/libintl.a ../lib/libbison.a
| -L/usr/local/lib -liconv
| I built libiconv from libiconv-1.7.tar.gz off ftp.gnu.org.

Hm...  I'll update to a more recent Gettext when I have time.  The
problem is the current Gettext has problems, so I wait for the next
one.  I hope it will fix you issue.

| It is the first time that bison actually goes beyond the first two
| tests sucessfully.  Before I simply stopped the test suite after seeing
| test 3, 4, 5 etc failed.

Could you dig why?  For instance, I'm highly interested in:

      cd tests
      ./testsuite -d -v -x 3 4 5
      ls testsuite.dir/0[345]

| All tests went well, except for test 40.

That's an expected failure, forget about it.

| Please review testsuite.log.

Please include it :)

| Thanks for your time.

Thanks for yours!

| Ciao, derweil,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]