[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug in bison 1.875

From: Paul Eggert
Subject: Re: bug in bison 1.875
Date: 11 Mar 2003 13:24:22 -0800
User-agent: Gnus/5.0808 (Gnus v5.8.8) Emacs/20.3

Martin MOKREJŠ <address@hidden> writes:

> 90. regression.at:280: testing Invalid inputs...
> regression.at:302: bison input.y
> --- -   2003-03-05 14:37:04.000000000 +0100
> +++ /scratch/bison-1.875/tests/testsuite.dir/at-stderr  2003-03-05 
> 14:37:04.000000000 +0100
> @@ -7,4 +7,5 @@
>  input.y:6.2: invalid character: `-'
>  input.y:7.1-8.0: missing `%}' at end of file
>  input.y:7.1-8.0: syntax error, unexpected "%{...%}"
> +fatal flex scanner internal error--end of buffer missed
> ...
> I've tried to compile cvs checkout, but I failed as I have too new
> autotools so bootstrap fails. :(

Which autotools are you using?  I regularly use the latest published
stable versions but I haven't run into this problem on 64-bit Solaris.

In particular, which flex version are you using?  I use 2.5.4.

> I've a short followup. I tried with CFLAGS="-O0 -g2" and now all of the
> tests pass.
> $ cc -V
> Compaq C V6.4-214 (dtk) on Compaq Tru64 UNIX V5.1A (Rev. 1885)
> Compiler Driver V6.4-014 (dtk) cc Driver

Quite possibly this is another bug in bison, which we haven't yet
fixed.  Unfortunately we don't have access to that compiler.  If you
can track the bug down yourself easily, that'd be nice (and thanks!).
Otherwise, when we generate the next test version of Bison, we'd
appreciate it if you tried it with that compiler and with the normal
optimization values; this should bypass any autotools mismatch issues
and we can focus on the actual problem.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]