[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing Bison from CVS

From: Hans Aberg
Subject: Re: Installing Bison from CVS
Date: Sat, 28 Apr 2007 13:34:41 +0200

On 28 Apr 2007, at 03:43, Joel E. Denny wrote:

I get the following error:
./bootstrap: autoconf --force ...
configure.ac:111: warning: AM_INTL_SUBDIR is m4_require'd but not m4_defun'd
m4/gettext.m4:362: AM_GNU_GETTEXT is expanded from...
configure.ac:111: the top level
configure:15873: error: possibly undefined macro: AM_INTL_SUBDIR
If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

The last couple of times this came up, it was due to an old M4.  For
example, Autoconf 2.61 requires at least M4 1.4.7.

I updates M4 from 1.4.7 to 1.4.9, and the problem persisted. I use Autoconf 2.61. (I also updated to Automake 1.9.6.) I checked versions (using --version) from the console I ran ./bootstrap (as root).

Which is the "official" method to get Bison from the CVS? On
it is suggested
cvs -z3 -d:pserver:address@hidden:/sources/bison co bison
followed, I gather, by
  cd bison
Is this right?

That's what I do.

And this was the method I used, to be sure I am doing the same thing as you. I run Mac OS X, version 10.4.9 (latest), which usually has very old GNU software. Are there any other Bison dependencies I might have overlooked?

  Hans Aberg

reply via email to

[Prev in Thread] Current Thread [Next in Thread]