[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem building DDD 3.3.1

From: John Gluck
Subject: Re: Problem building DDD 3.3.1
Date: Sun, 17 Mar 2002 21:22:52 -0500

Hi Ray

I ran the command you requested below after removing everything and unravelling
the tarball again.
This time it terminates with a message:

+ echo 'configure: error: installation or configuration problem: C compiler
cannot create executables.'
configure: error: installation or configuration problem: C compiler cannot
create executables.
+ exit 1
+ echo 'configure: error: ./configure failed for readline'
configure: error: ./configure failed for readline
+ exit 1

Obviously, the compiler not being able to create executables is incorrect. After
all, I've compiled lots of things.

I did a ps -eaf and the only thing I see is a bash -i (guess that's a shell
spawned by script)

The file file created by script is attached in gzipped form.


J.H.M. Dassen (Ray)" wrote:

> On Sun, Mar 17, 2002 at 13:53:45 -0500, John Gluck wrote:
> > As requested I am attaching the files:
> Please Cc the mailing list so others can have a shot at this problem as
> well.
> > ddd.config is the script log of the command you asked me to run.
> > config.log is the file produced when running configure from the command you
> > asked for.
> Hmm... there's two things unfortunate about them:
> - the "-x" isn't effective for the call to configure in the 'ddd' subdir
> - the log seems to miss some crucial info at the end
> Please retry with
>         env SHELLOPTS=xtrace CXX="g++ -v" CC="gcc -v" ./configure -v
> (which should do the -x to scripts invoked from the top-level configure as
> well) and be sure to use the 'script' command rather than shell redirection
> to produce the log.
> > My system started life as a Slack 8.0 system but I rebuilt pretty much
> > everything from later versions downloaded from the net.
> Hmm... personally I find that a very tedious method for keeping a system up
> to date; I prefer to run Debian unstable and use my coding/build experience
> to help develop it so that others can profit as well.
> > I used the configure in the tarball as is for a first try. When that
> > didn't work I tried to remake configure but that didn't work either. Then
> > I deleted everything and untarred and tried agian with the original
> > configure. What is attached is from the configure in the tarball as is.
> > From what I can see the macro that checks for  ostrstreambuf::freeze() is
> > getting stuck. I wonder if it might be a perl thing???
> I strongly doubt that. I don't see anything in the configure script using
> perl.
> Frankly, your problem is a bit mystifying. The check on which your system
> gets stuck is quite similar to other tests it has already run succesfully
> (create a small test source, compile it using flags already determined, try
> to run it and look at the result).
> Perhaps you can also do a "ps -eaf" or similar once configure has gotten
> stuck; it would be interesting to know whether the problem lies in running
> the compiled test file or elsewhere.
> Ray
> --
> To this day we are still wondering what exactly it is, besides prices, that
> Microsoft has innovated.
>         Seen on segfault.org

Attachment: ddd.config.gz
Description: GNU Zip compressed data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]