[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fwd: findutils bug

From: James Youngman
Subject: Fwd: findutils bug
Date: Sun, 2 Apr 2006 21:36:32 +0100

Ross, there's no point sending thre response to just me - if you do
that, how will anybody elese help?

Did you mean to send a zero-byte strace.txt file as an attachment?  
It looks empty to me, at least.


---------- Forwarded message ----------
From: address@hidden <address@hidden>
Date: Apr 2, 2006 7:39 PM
Subject: Re: findutils bug
To: James Youngman <address@hidden>

> On 4/1/06, Ross Wolin <address@hidden> wrote:
>>    Hi,
>>    I'm having a problem using cygwin's find on WinXP.    It works fine
>> when I
>>    run it on a local drive, but when I run it on my network drive, it
>> tells me
>>    directories don't exist, i.e.
> What about plain files?

Find does find the plain files on the network drive - but it's giving
errors on the directories, saying they don't exist.

> Do the things that apparently don't exist
> actually exist?

Yes - I have used the files on that server for several years.

>Is there a difference in the cases of the names?

A few directory names contain upper case letters but most of them are all
lower case.

>>      V:\>find
>>      .
>>      ./mp3
>>      find: ./mp3: No such file or directory
> Can you reference ./mp3 (spelled exactly like that, with the leading
> dot-slash) from the same working directory?


> Does the problem happen if you run find on the local disk of the
> Cygwin box?


> What about if you run find against a Samba sever running
> something other than FreeBSD, or if you run it against an installation
> of Samba with the default configuration or a different version of
> Samba?

I only have one Samba server and don't really want to reconfigure it.
It's used for my business and has worked for years with Win98, WinNT,
WinXP, Debian Linux, and FreeBSD.

I just recent started using the igrep package with XEmacs, which calls
find and grep, and that's when the problems started.

> See above for some ideas.  If strace or ltrace work on Cygwin, those
> might provide useful diagnostics.   Also, try asking for help on the
> Cygwin mailing list.


Incidentally, when I run find 4.1.7 on another machine with an older
installation, it works correctly with the Samba drive.   The cygwin1.dll
version on that machine is 1.5.10-0x5E6/2004-05-25 22:07.

The machine that doesn't work has find/4.3.0 and
cygwin1.dll/1.5.19-0x5EF/2006-01-20 13:28
On that machine that did not work, I also tried the newest snapshot of the
cygwin1 dll (at the suggestion of another developer) but the failure was
exactly the same.


Attachment: strace.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]