[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Wolter Bernd
Subject: find-dired
Date: Fri, 30 Nov 2001 12:21:42 +0100 (MET)

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (i386-msvc-nt4.0.1381)
 of 2001-10-24 on SPARKYBEAR
configured using `configure --with-msvc (12.00)'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: DEU
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: nil

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

I use the above binary of emacs21 under WinNt4 SP6 (and also under
Win95) together with cygnus-bash (cygwin-b20). When I do ´M-x
find-name-dired' I get the following error message in the *Find*

|   c:/:
|   find . \( -name '.emacs' \) -exec ls -ld {} \;
|   /cygnus/cygwin-b20/H-i586-cygwin32/bin/bash.exe: -c: line 1: syntax error 
near unexpected token `\\('
|   /cygnus/cygwin-b20/H-i586-cygwin32/bin/bash.exe: -c: line 1: `find . \\( 
-name '.emacs' \\) -exec ls -ld {} \\;'
| find exited abnormally with code 2 at Fri Nov 30 11:37:45

I set debug-on-entry for find-dired and stepped through the program up

| * start-process("find" #<buffer *Find*> "bash.exe" "-c" "find . \\( -name 
'.emacs' \\) -exec ls -ld {} \\;")

where bash produced the error-message quoted above.

Two things I checked additionally:

if I cut the ´find . \( -name...' line from the error message and do
´M-x shell' and paste it there it will run without problems.

I also checked ´find-name-dired' in emacs20.4 with the exact same
bash-setup as in 21 with debug-on-entry and there emacs passes exactly
the same start-process arg-list to bash and it completes without a

I tried to track where the additional quoting is done
(start-process-shell-command) and replaced the double quotes with
single one - then bash gets to see the ´( -name '.emacs' )' part
without quotes at all which will result in a different error. I
replaced the 21 ´start-process-shell-command' with the one from 20.4 -
same error as above.

It seems to happen on the way from start-process to the shell on a
very low level I don't have access to.

I read about problems with start-process in etc/PROBLEMS and changed
the start-process call in subr.el to call-process - same error.

If I can do any additional checking, debugging or backtracing I'd be
glad to oblige since I really miss this sorely.

All the best

Bernd Wolter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]