bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs/JDE browser error (winXP problem?)


From: Stefan Monnier
Subject: Re: Emacs/JDE browser error (winXP problem?)
Date: 01 Dec 2001 22:01:54 -0500
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1.50

>>>>> "Joseph" == Joseph Nunn <address@hidden> writes:
> I've just installed the newest versions of emacs 21.1, cygwin, and jde
> 2.2.8 on my brand new win xp system ( sorry, I know you guys probably
                        ^^^
Around here we don't call this a `win'.

> haven't had a chance to check this os out), along with the latest jdk 1.4
                ^^^^^^
And I wouldn't call that a chance either.

> Debugger entered--Lisp error: (void-variable browse-url-new-window-p)
>        jde-run-applet()
>        jde-run-menu-run-applet()
>        call-interactively(jde-run-menu-run-applet)

If you do C-h N and search for that void-variable, you'll find:

    ** The user-option `browse-url-new-window-p' has been renamed to
    `browse-url-new-window-flag'.

so it's an incompatibility introduced by Emacs-21.1 and JDE bumped into it.
Maybe there's a newer JDE that works around this problem.  Otherwise,
go through jde's .el files and replace all occurrences of
browse-url-new-window-p with browse-url-new-window-flag.


        Stefan



reply via email to

[Prev in Thread] Current Thread [Next in Thread]