bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: segv in 21.1 on Irix


From: Rohan Hart
Subject: Re: segv in 21.1 on Irix
Date: Sat, 12 Jan 2002 14:05:48 +1300

Eli Zaretskii writes:
 > > From: address@hidden (Rohan Hart)
 > > Newsgroups: gnu.emacs.bug
 > > Date: 10 Jan 2002 15:00:09 -0800
 > > 
 > > What's causing the crash is a failure of runtime linker (rld) to find
 > > the function "setutent" which is very strange considering it's in
 > > libc.so.  After playing around with rld for a while I found that
 > > forcing early binding of symbols by setting the environment variable
 > > LD_BIND_NOW to 1 has (so far) stopped it from occuring.
 > 
 > This is very strange: I use Emacs 21 on SGI Irix 6.5 all the time,
 > and never saw even a single crash due to these problems.
 > 
 > Could you please send the list of versions of all the tools that
 > could be related to this (compiler, linker, rld, etc.)?

gcc is 2.95.2 from the SGI freeware site
cc, ld32 and as are MIPSpro Compilers: Version 7.2.1
rld is version 7.3 for IRIX6.5.3n32 ABI Dec 23 1998 02:12:48

I've had to install a local copy of libXpm as the IRIX one is slightly
too old.

I've compiled on a an R10k IP27 (Origin) system and run on an R5k IP32
(O2) system.  While n32 objects are usually mips3 this system has been
setup to build mips4 by default.  The libraries are a mix of mips3 and
mips4.  If it makes a different the rld version on the compiling
machine is 7.3.1.2 n32 ABI Oct 20 2000 04:05:57

thanks
Rohan



reply via email to

[Prev in Thread] Current Thread [Next in Thread]