bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

smtpmail.el spinning


From: jglauner
Subject: smtpmail.el spinning
Date: Wed, 4 Feb 2004 10:59:12 -0500

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.2.1 (i386-debian-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2002-03-22 on raven, modified by Debian
configured using `configure  i386-debian-linux-gnu --prefix=/usr 
--sharedstatedir=/var/lib --libexecdir=/usr/lib --localstatedir=/var/lib 
--infodir=/usr/share/info --mandir=/usr/share/man --with-pop=yes --with-x=yes 
--with-x-toolkit=athena --without-gif'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: C
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

The e-mail listed below describes my situation.  Basically, when I
send a message with VM, something in smtpmail.el is spinning, sucking
up CPU.  It looks like it's waiting for the response from "QUIT".

--BEGIN--

From: Kyle Jones <address@hidden>
To: address@hidden
Subject: Re: send (C-c C-c) sends, but hangs VM, requires C-g
Date: Wed, 4 Feb 2004 07:52:30 -0800

address@hidden writes:
 > Here is the stacktrace...  One line was really long, so I put "\" at
 > the breaks:
 >
 > Debugger entered--Lisp error: (quit)
 >   accept-process-output(#<process SMTP>)
 >   smtpmail-read-response(#<process SMTP>)
 >   byte-code("address@hidden"\210?^H!\210?^H!\210)?\207" \
 >     [process process-buffer smtpmail-send-command "QUIT" \
 >      smtpmail-read-response delete-process] 3)
 >   smtpmail-via-smtp((#("address@hidden" 0 17 (fontified nil))) #<buffer  
 > smtpmail temp>)
 >   smtpmail-send-it()
 >   mail-send()
 >   vm-mail-send()
 >   vm-mail-send-and-exit(nil)
 >   call-interactively(vm-mail-send-and-exit)
 >
 > I noticed, too, that when it is hanging, emacs takes up 95%+ of my cpu
 > cycles.

Emacs is apparently spinning inside smtpmail.el.  It looks like
it is waiting for the response to the SMTP QUIT command.  You
should take this problem up with the Emacs maintainers.

--END--


Recent input:
DEL DEL DEL DEL DEL s e n d - g DEL b u g TAB TAB DEL 
DEL DEL DEL DEL DEL DEL DEL b u g TAB TAB M-x a p r 
o TAB RET b u g RET C-x o C-v C-v C-v C-v C-s r e p 
o r t RET C-s C-s C-s C-s C-s C-s C-g q M-x r e p o 
r t - e m TAB RET C-g C-x o w C-g w DEL DEL DEL DEL 
DEL e m a c s b u g RET M-x ESC O A RET

Recent messages:
Stuffing attributes... done
Saving...
Saving file /home/jglauner/mail/inbox...
Wrote /home/jglauner/mail/inbox
call-interactively: Quit
Loading apropos...done
Mark saved where search started
isearch-abort: Quit
byte-code: Quit [2 times]
Message written to /home/jglauner/emacsbug





reply via email to

[Prev in Thread] Current Thread [Next in Thread]