bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make for emacs fails under OS X 10.5


From: Ted Zlatanov
Subject: Re: make for emacs fails under OS X 10.5
Date: Mon, 05 Nov 2007 13:14:34 -0600
User-agent: Gnus/5.110007 (No Gnus v0.7) Emacs/22.1.50 (darwin)

On Sat, 03 Nov 2007 13:46:57 +0900 William Xu <address@hidden> wrote: 

WX> Ted Zlatanov <address@hidden> writes:
>> This has been reported to the emacs-devel mailing list repeatedly.  It
>> was probably introduced with the Unicode merge in August.  

WX> Hmm, i'm running it happily now with: 

WX> ,----[ emacs-version ]
WX> | GNU Emacs 23.0.50.9 (powerpc-apple-darwin8.10.0, Carbon Version 1.6.0)
WX> | of 2007-10-20 on enjoy-life
WX> `----

WX> I built it on osx 10.4.10, with option, `--prefix=$HOME --with-carbon
WX> --without-x'.

WX> And the other thing is that i disable the fink in the `configure' file
WX> by applying nofink.patch from carbon emacs 22.1. (since i couldn't even
WX> bootstrap emacs with fink, and i also don't understand why people refuse
WX> to remove it)

I use Darwin Ports, no Fink.  gcc comes from the Apple dev tools.

I am still experiencing the problem, and I'm pretty sure it hasn't
changed since August when I first noticed it.  Please try making a clean
build with any version between August and now, on OS X 10.4 or 10.5, and
you'll see the input problem.  If you really are not having the input
problem with the build you mention above, maybe it doesn't occur on PPC
platforms (i386 here).  I'm very curious about your build, because no
one else has reported success on MacOS as you have.

The last good build for me was 
GNU Emacs 22.1.50.2 (i386-apple-darwin8.10.1, Carbon Version 1.6.0) of 
2007-08-01 on tzz.local

and the last build I tried, which has the input problem:
GNU Emacs 23.0.50.1 (i386-apple-darwin9.0.0, Carbon Version 1.6.0) of 
2007-08-01 on tzz.local

WX> So i guess the slow responsiveness is introduced either by recent cvs
WX> changes(20071020 - now) or osx changes(10.4 -> 10.5). 

It's definitely not OS X 10.4 vs 10.5.  I have observed the input
problem on both (10.4.10 and 10.5).

WX> Since I built cvs emacs regularly, looks like i could still run cvs
WX> emacs built after 20071020, but i couldn't remember the exact revision
WX> that introduced this problem. (And i have no osx 10.4 anymore..)

Ted


reply via email to

[Prev in Thread] Current Thread [Next in Thread]