[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3122: Error saving commit messages for bazaar (bzr).

From: Novimir Pablant
Subject: bug#3122: Error saving commit messages for bazaar (bzr).
Date: Tue, 28 Apr 2009 22:58:42 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

file-attributes gives:
(nil 1 1006 513 (18935 56919) (18935 56919) (18935 55764) 15788 "-rw-rw-rw-" nil (768 1 . 15292) 1830808)

user-real-login-name gives:

file-attributes gives the same result outside of a bzr commit. When not in the middle of the commit insert-file-contents works fine.

I have tried accessing the file during a commit (after 'bzr commit' has been entered and while the emacs window is still open) with several other programs:

notepad: Opens file.
type (in cmd.exe): Error: The process cannot access the file because another process has locked a portion of the file.

cygwin: Cannot copy (cp) or view (cat).
explorer: Can copy.

So this is a file lock issue and not a permissions issue. The file is indeed readable. While I don't know exactly what bazaar has set for that file it seams reasonable that it would lock it.


On 4/27/2009 11:25 AM, Eli Zaretskii wrote:
Date: Sun, 26 Apr 2009 22:52:45 -0700
From: Novimir Pablant<address@hidden>
Cc: address@hidden

I installed Emacs- and tried reproducing the error.

I still get the error, but now the file is saved anyway.  This is
certainly an improvement.

Still using emacs23 I tried the two commands:

M-: (file-readable-p
"c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

Responds t

M-: (insert-file-contents
"c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

Gives the error (from the Backtrace):
Debugger entered--Lisp error: (error "IO error reading
Permission denied")

What does the following command produce?

   M-: (file-attributes
    "c:/library/code/python/annotatex/releases/test/.bzr/checkout/dirstate") RET

Also, what does the following display?

   M-: (user-real-login-name) RET

(I suspect that somehow this file was made unreadable for you,
i.e. private to another user.  Assuming you are on Windows XP, the
test in file-readable-p does not take into account Windows native
security settings enforced through ACLs.  So it could think the file
is readable by you, when it really isn't.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]