bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#7908: png-1.5 fix for emacs-23.2 and HEAD


From: Chong Yidong
Subject: bug#7908: png-1.5 fix for emacs-23.2 and HEAD
Date: Sat, 29 Jan 2011 13:29:32 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

Eli Zaretskii <address@hidden> writes:

> Sorry, I used an old patch.  But with this line corrected, the
> compilation still fails with the same error message.
>
> (I'm using libpng 1.4.x here, but I modified the #ifdef conditionals
> to make the new code in effect on 1.4.x.  Maybe that's the reason for
> the difference?)

Yeah, it makes a big difference.  png_set_longjmp_fn is new to
libpng-1.5, it's the new non-backward compatible way to access the png
jmpbuf.

If it's too much trouble for you to install libpng 1.5 on Windows, I
think I'll go ahead and commit the patch.  The way the conditionals are
now written, compilation with libpng 1.4 is unaffected, so it should be
very safe.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]