[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9354: wishing to build, ./configure runs eternally

From: Алиса Безкреста
Subject: bug#9354: wishing to build, ./configure runs eternally
Date: Wed, 24 Aug 2011 01:29:05 +0400


I ran apt-get build-dep emacs23 with result: 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I took
gunzipped it and untarred it.

I entered the resulting source directory emacs-23.3 and ran ./configure.

Then ./configure started to check and when it ended, without pause, it repeated the same checkings, and again and again...
Since it refused to stop by itself, I stopped it manually with C-z.

Then I removed the source directory emacs-23.3 and extracted a fresh one from the tarball.

Again I entered the source directory and ran ./configure.

Again it ran eternally.

I repeated this exercise a few times.

Whenever I stopped ./configure some tens of minutes after starting it, I noticed that it had created a few new files in the source directory but no Makefile

Whenever I allowed ./configure to run several hours before stopping it, I noticed that it had created in the source directory a whole army of new files, most of them with a name starting with conf followed by some random characters. An example: confTgLUip, confTxjcW5, confuo2ySs, confWbNvqm, confWO1cJQ, confWzfwLE, ...
Besides these conf* files it had also created a Makefile. But when I ran make, it just continued with the checking over and over again.

I also noticed that the longer I left ./configure run, the more new processes were being started. After some hours they amounted to hundreds, all but few named /bin/bash ./config.status and make epaths-force.

This means that no usable Makefile is created in an acceptable time, as far as I accept to wait, so I can't use make to build emacs.

I wonder if everything is all right, so should I wait longer, for instance: several days, to configure to finish.

Or, configure is good, but there is something with my machine and OS that makes configure go mad.

Or, something is wrong with configure.

Best regards

Alisa Bezkresta

reply via email to

[Prev in Thread] Current Thread [Next in Thread]