[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#8368: 24.0.50; "temp" means "help" - rename or at least document

From: Drew Adams
Subject: bug#8368: 24.0.50; "temp" means "help" - rename or at least document
Date: Sat, 28 Apr 2012 07:00:40 -0700

> (1) In my Emacs I moved `internal-temp-output-buffer-show' to 
> Elisp and intend to apply this change to the trunk soon.
> Other from that, leave `with-output-to-temp-buffer' unchanged.
> (2) Provide a new macro which does almost the same as
> `with-output-to-temp-buffer', runs similar hooks ...  Maybe 
> we find some improvements though.
> (3) Change all callers of `with-output-to-temp-buffer' in Emacs 24 to
> use the new macro and *not permanently* add their functions to the new
> hooks.  Whether we use another wrapper for this like 
> `with-help-window' or bind the hook temporarily seems a matter of taste.
> (4) Declare `with-output-to-temp-buffer' obsolete.

Hi Martin,

I'm not sure I understand all of your proposal, but I think I agree.  Let me
just say this.  If it is addressed already by your proposal (I think so), great.
If not, maybe you can try to take it into consideration.

Whether we have one or more different macros to distinguish temporary from help
displays does not matter much to me.  Likewise, the names of the macros or
whatever are not what is most important (to me).  Obviously, if possible, I
would prefer that the names reflect the meaning/behavior - so, e.g. "temp" in
one name and, say, "help" in the other.  And maybe it makes sense to derive the
help mode from the temp mode - dunno.

What is important to me is that we distinguish the two (or more) so that
programmers at least have a simple, clean way to display something in a
temporary buffer with no supposition that that buffer should also be a help
buffer.  I.e., without removing and re-adding the help-mode hooks.

Probably we will need to leave the original name for the current behavior, but
if it could be aliased to something with "help" in the name, and then the
original name deprecated, that would be better.  (I think that's part of what
you suggest.)  And create a new name for the temp-without-the-help-stuff case.

Whatever you decide will I'm sure be better than the hard-coded
take-it-or-leave-it situation we have now.  And splitting the two this way will
also reduce any pressure (e.g., from users like me) not to add more help stuff
to the help-mode version.

I hope this can be done soon.  It's been over a year since the bug report was

Thx - Drew

reply via email to

[Prev in Thread] Current Thread [Next in Thread]