[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#14168: 24.3.50; vc: Incorrect 'vc-bzr-print-log' when 'start-revisio

From: Lluís Vilanova
Subject: bug#14168: 24.3.50; vc: Incorrect 'vc-bzr-print-log' when 'start-revision' and 'limit' are set
Date: Sun, 21 Apr 2013 20:57:05 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Glenn Morris writes:

> Lluís Vilanova wrote:
>>> Are you sure this isn't a confusion about what is meant by "starting
>>> from the revision"?
>> Might well be. I understand it as "from given revision to newest
>> revision".

> This area is confusing. It is not well documented and inconsistently
> implemented. The only documentation we have is in the commentary of
> vc.el:
> In practice, the only place in Emacs that uses this is
> vc-annotate-show-log-revision-at-line, which shows a single revision
> only. So we have no way to tell what the intended behaviour is when
> LIMIT != 1.

> We should either document that it only works for LIMIT = 1, or decide
> what it is supposed to do and make it consistent.
> I'm guessing that START was supposed to be the newest revision, which is
> the opposite of what I (like you) first thought.

> I have no idea how to sensibly combine this with someone having "bzr log"
> aliased to "bzr log --forward".

>    bzr log --forward -r ..3 --limit 2 

> will display revisions 1 and 2 rather than 2 and 3. There doesn't seem
> to be a simple way to get the latter.

> https://lists.ubuntu.com/archives/bazaar/2007q4/035828.html
>    You are correct that the --limit option does not make much sense with
>    the --forward option.  It is not meant to.
> https://bugs.launchpad.net/bzr/+bug/320920

> I don't know if we should bother trying to figure it out given that the
> only caller of this uses LIMIT == 1. I'd probably just stick a
> --no-aliases in there.

Nice, I didn't know about the "--no-aliases" argument, and that might prove
useful. As a side note, I sent a small patch for the case where LIMIT is 1.

Looking at the code, I'd rather rename START-REVISION as REVISION, which I think
would be less confusing given the current semantics.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]