bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25548: 25.1; Wrong Emacs version for Emacs 25.1.2 (?)


From: Noam Postavsky
Subject: bug#25548: 25.1; Wrong Emacs version for Emacs 25.1.2 (?)
Date: Fri, 27 Jan 2017 13:30:21 -0500

On Fri, Jan 27, 2017 at 1:13 PM, Drew Adams <address@hidden> wrote:
>
> GNU Emacs 25.1.1 (x86_64-w64-mingw32) of 2016-11-15
>
> It says 25.1.1, not 25.1.2.
>
> Still looking for an explanation of such numbering, in both
> the output of `emacs-version' and the zip-file name.

The zip-file name convention of X.Y-2 is new, and it hasn't been
documented yet. Adding a mention in the README next to the archives
would make sense.

Regarding 25.1.1 vs 25.1.2 I think this text in `(elisp) Version Info'
explains it:

 -- Variable: emacs-version
     The value of this variable is the version of Emacs being run.  It
     is a string such as ‘"23.1.1"’.  The last number in this string is
     not really part of the Emacs release version number; it is
     incremented each time Emacs is built in any given directory.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]