[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33619: 26.1.90; Tramp "simplified" syntax completion problem

From: David Hull
Subject: bug#33619: 26.1.90; Tramp "simplified" syntax completion problem
Date: Tue, 4 Dec 2018 17:14:16 -0800

Filename completion does not work with tramp's "simplified" syntax.

  (load-library "tramp")
  (tramp-change syntax 'simplified)

Now if I run find-file and type "//cos6:src/ss" and then TAB I get the error:

  completion--some: Wrong type argument: stringp, ""

(My remote host is named "cos6" and it has a "src/ssrtb-server" directory.)

If I set the the tramp-syntax back to 'default then completion works. Completion worked with the "simplified" syntax in emacs 26.1.

In GNU Emacs 26.1.90 (build 1, x86_64-apple-darwin18.2.0, NS appkit-1671.10 Version 10.14.1 (Build 18B75))
 of 2018-12-03 built on mbp-109-op-04
Repository revision: 8d7e58ce9f389d77323e0237c22c4e13cb68b8e7
Windowing system distributor 'Apple', version 10.3.1671
Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.
Quit [3 times]
Making completion list...
Loading tramp...done
completion--some: Wrong type argument: stringp, ""
Quit [3 times]
Configured using:
 'configure --with-ns '--enable-locallisppath=/Library/Application
 Support/Emacs/site-lisp' --with-modules'

Configured features:

Important settings:
  value of $EMACSDATA: /Users/david.hull/Applications/Emacs.app/Contents/Resources/etc
  value of $EMACSLOADPATH: /Users/david.hull/Applications/Emacs.app/Contents/Resources/lisp:/Users/david.hull/Applications/Emacs.app/Contents/Resources/lisp/leim
  value of $LC_COLLATE: C
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8-unix

Major mode: Fundamental

Minor modes in effect:
  shell-dirtrack-mode: t
  tooltip-mode: t
  global-eldoc-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  buffer-read-only: t
  line-number-mode: t
  transient-mark-mode: t

Load-path shadows:
None found.

(shadow sort mail-extr emacsbug message rmc puny seq dired
dired-loaddefs rfc822 mml mml-sec epa derived epg epg-config gnus-util
rmail rmail-loaddefs mm-decode mm-bodies mm-encode mail-parse rfc2231
mailabbrev gmm-utils mailheader sendmail rfc2047 rfc2045 ietf-drums
mm-util mail-prsvr mail-utils tramp-cache tramp-sh cus-edit easymenu
cus-start cus-load wid-edit tramp-cmds tramp tramp-compat tramp-loaddefs
trampver shell pcomplete comint ansi-color ring parse-time format-spec
advice auth-source cl-seq eieio byte-opt bytecomp byte-compile cconv
eieio-core cl-macs gv eieio-loaddefs cl-loaddefs cl-lib password-cache
elec-pair time-date tooltip eldoc electric uniquify ediff-hook vc-hooks
lisp-float-type mwheel term/ns-win ns-win ucs-normalize mule-util
term/common-win tool-bar dnd fontset image regexp-opt fringe
tabulated-list replace newcomment text-mode elisp-mode lisp-mode
prog-mode register page menu-bar rfn-eshadow isearch timer select
scroll-bar mouse jit-lock font-lock syntax facemenu font-core
term/tty-colors frame cl-generic cham georgian utf-8-lang misc-lang
vietnamese tibetan thai tai-viet lao korean japanese eucjp-ms cp51932
hebrew greek romanian slovak czech european ethiopic indian cyrillic
chinese composite charscript charprop case-table epa-hook jka-cmpr-hook
help simple abbrev obarray minibuffer cl-preloaded nadvice loaddefs
button faces cus-face macroexp files text-properties overlay sha1 md5
base64 format env code-pages mule custom widget hashtable-print-readable
backquote threads dbusbind kqueue cocoa ns multi-tty
make-network-process emacs)

Memory information:
((conses 16 237760 12374)
 (symbols 48 23427 1)
 (miscs 40 71 206)
 (strings 32 39299 1776)
 (string-bytes 1 1132795)
 (vectors 16 39286)
 (vector-slots 8 771090 18152)
 (floats 8 73 64)
 (intervals 56 230 0)
 (buffers 992 13))

reply via email to

[Prev in Thread] Current Thread [Next in Thread]