bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33619: 26.1.90; Tramp "simplified" syntax completion problem


From: Michael Albinus
Subject: bug#33619: 26.1.90; Tramp "simplified" syntax completion problem
Date: Wed, 05 Dec 2018 10:05:31 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

David Hull <address@hidden> writes:

Hi David,

Thanks for the report.

> Filename completion does not work with tramp's "simplified" syntax.
>
>   (load-library "tramp")
>   (tramp-change syntax 'simplified)
>
> Now if I run find-file and type "//cos6:src/ss" and then TAB I get the
> error:
>
>   completion--some: Wrong type argument: stringp, ""
>
> (My remote host is named "cos6" and it has a "src/ssrtb-server"
> directory.)
>
> If I set the the tramp-syntax back to 'default then completion works.
> Completion worked with the "simplified" syntax in emacs 26.1.

I've tried to reproduce it with the current emacs-26 branch on an Ubuntu
18.10 machine. You're on a macOS machine, but this shouldn't matter.

The problem doesn't happen to me.

Could you pls start "emacs -Q -l tramp", change the Tramp syntax, and
try to reproduce the problem? Does it still happen?

In case of yes, could you perform (setq debug-on-error t) prior the
test, and show the resulting backtrace?

Thanks, and best regards, Michael.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]