[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#30929: 26.0.91; Text drag and drop does not work

From: Nick Helm
Subject: bug#30929: 26.0.91; Text drag and drop does not work
Date: Mon, 07 Jan 2019 23:38:33 +1300

On Sun, Jan 6, 2019 at 5:20 AM, Alan Third <address@hidden> wrote:
No problem. Can you have a look at the attached. It’s not as ambitious
as we discussed, but it does pretty much the minimum required to make
drag and drop usable.

If you think the defaults I’ve chosen don’t make sense, I’m happy to change them. I don’t ever use drag and drop, so I don’t know what’s
really useful for people.

Thanks, this is a big improvement.

I like the default modifier actions - they match how drag and drop works
on my other apps. I was worried having the modifiers independent of the
Emacs modifiers might be a bit confusing with non-default bindings, but
in practice it doesn't cause me any trouble.

I also tried as many different dnd operations as I could think of. They
all worked as expected except one - when I try to open a malformed URL
Emacs creates a spurious buffer and freezes momentarily (C-g to clear).
Specifically, I selected the text "file://~/test.txt" in TextEdit.app
and dropped it into Emacs with Alt/Opt held down. Properly formed URLs
work as expected and open the file.

Thanks again for working on this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]