[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUAstro on Ubuntu 22

From: Mohammad Akhlaghi
Subject: Re: GNUAstro on Ubuntu 22
Date: Wed, 12 Oct 2022 23:29:10 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.3.3

Hi Aaron,

Thanks a lot for reporting this. I just tried building a fresh Ubuntu 22.04 image in a virtual machine and indeed, noticed that it builds some packages like GNOME or Firefox with 'snap'!

I also noticed that indeed, it has a libgit2 instance there, under GNOME (in the same location you gave). But this was just out of the fresh install, before I actually run 'sudo apt install libgit2-dev'.

After installing all the dependencies with apt following [1], I noticed that it actually does install libgit2 outside of 'snap' in the standard '/lib/x86_64-linux-gnu' directory.

I then build Gnuastro from source and the only problem was that it couldn't find libgnuastro, so I ran:

export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/local/lib"

Afterwards Gnuastro programs ran correctly. To confirm, I checked the libraries that Gnuastro links against (with the 'ldd' command):

$ ldd $(which astnoisechisel)
    linux-vdso.so.1 (0x00007fff593ce000)
libgnuastro.so.17 => /usr/local/lib/libgnuastro.so.17 (0x00007f9db9d43000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f9db9b0b000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f9db9a24000)
libgit2.so.1.1 => /lib/x86_64-linux-gnu/libgit2.so.1.1 (0x00007f9db9924000)
    libtiff.so.5 => /lib/x86_64-linux-gnu/libtiff.so.5 (0x00007f9db989e000)
    libjpeg.so.8 => /lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f9db981b000)
    libwcs.so.7 => /lib/x86_64-linux-gnu/libwcs.so.7 (0x00007f9db969e000)
libcfitsio.so.9 => /lib/x86_64-linux-gnu/libcfitsio.so.9 (0x00007f9db9397000)
    libgsl.so.27 => /lib/x86_64-linux-gnu/libgsl.so.27 (0x00007f9db90d8000)

We see that indeed, Gnuastro was built with '/lib/x86_64-linux-gnu/libgit2.so.1.1'.

It is very strange that you needed to run the configure script in sudo mode! I didn't need to do it.

I think these complications occurred because you updated the previous Ubuntu and the 'snap' issue has cause some complications. In the days that I used "point release" [2] operating systems (like Ubuntu), I also confronted such issues when updating. For such operating systems, its always easier to just format the disk and install a fresh one from scratch ;-).

Later, I moved to Arch GNU/Linux (which is "rolling release" [3]); and I never have this problem; although I still regularly format my whole operating system partition and install a new one from scratch, simply because of all the un-used software and settings that bloat the system.

In my Arch, I also have problems with Wayland (mostly with sharing screen during meetings), so at log-in time, I just select to load "GNOME on Xorg" ;-).

Thanks again for sharing this experience, it may indeed happen to others and this will hopefully show up in search results later.


[1] https://www.gnu.org/software/gnuastro/manual/html_node/Dependencies-from-package-managers.html
[2] https://en.wikipedia.org/wiki/Point_release
[3] https://en.wikipedia.org/wiki/Rolling_release

On 10/7/22 10:05, A. Emery Watkins wrote:
Hi Mohammad,

So, just for fun, I decided to try updating my laptop to use Ubuntu 22.04.1
LTS.  Naturally this broke a lot of things, one of which was GNUAstro.  I
re-installed it successfully (version 18, the latest one I could find in my
inbox), but there's apparently a critical issue involving the path to a
particular library.

When I run astnoisechisel from the command line (or any other GNUAstro
utility), I get this:
$ astnoisechisel: error while loading shared libraries: libgit2.so.28:
cannot open shared object file: No such file or directory

Ubuntu 22 favors something called "snap" for certain applications.  That
particularly library file is here on my
system: /snap/gnome-3-38-2004/115/usr/lib/x86_64-linux-gnu/libgit2.so.28

So it seems that even after a successful installation, GNUAstro doesn't
look in the /snap directory for some necessary libraries, and so throws
that error.

Also of note is that I needed to do sudo ./configure to install this time,
otherwise it couldn't find the CFITSIO libraries even after pointing to the
right paths.  I don't recall having to do that before, so likely that's
another Ubuntu 22 quirk.  I suppose explicitly pointing to the Anaconda
CFITSIO files could work, since those are all in my home directory, but I
didn't try.

Personally, I may re-install version 21 (22 also uses Wayland, which
doesn't play nice with my external monitor in my office or with IPython),
but for those braver than me, those are some of the issues I found trying
to use GNUAstro with version 22.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]