[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUAstro on Ubuntu 22

From: A. Emery Watkins
Subject: Re: GNUAstro on Ubuntu 22
Date: Thu, 13 Oct 2022 13:48:10 +0100

Ah, okay.  I don't need JPEG functionality, so I tried just doing make install.  Worked fine, but now when I run any GNUAstro utilities I get this:

astnoisechisel: error while loading shared libraries: libjpeg.so.9: cannot open shared object file: No such file or directory

Was there some flag I needed to include on configuration or something to tell it to not look for that?

On Thu, Oct 13, 2022 at 1:41 PM Mohammad Akhlaghi <mohammad@akhlaghi.org> wrote:
That is strange!

But the good thing is that this just a run-time issue. During
compilation it has been able to find them.

You can fix this by updating 'LD_LIBRARY_PATH' [1], but you have to find
where Ubuntu actually installed it!?!

If you don't need to convert FITS images to and from JPEG images, you
can safely ignore this and do 'sudo make install' ;-).


[1] https://www.gnu.org/software/gnuastro/manual/html_node/Known-issues.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]