[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Much reduced board decoration with 3D board

From: Russ Allbery
Subject: Re: [Bug-gnubg] Much reduced board decoration with 3D board
Date: Tue, 08 Dec 2009 19:06:18 -0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)

Russ Allbery <address@hidden> writes:

> QuickDraw was off.  I turned it on and saw the same thing.  I did
> double-check that the option to show the targets is on, and tried
> toggling it to no effect.  The computer player moves do show an animated
> checker, and I think my moves show an animated checker when I finish the
> move (although it's very fast), but the checker doesn't move when
> dragged and there are no targets.

I tried to do more debugging, but I got lost in what calls what with the
3D board rendering.  However, one additional, potentially useful piece of
information: I annotated board3d/drawboard3d.c:drawPieces thusly:

        if (bd->DragTargetHelp)
        {       /* highlight target points */
                glPolygonMode(GL_FRONT, GL_LINE);
                SetColour3d(0.f, 1.f, 0.f, 0.f);        /* Nice bright green... 

/* =====> */    printf("Displaying target help points\n");
                for (i = 0; i <= 3; i++)
                        int target = bd->iTargetHelpPoints[i];
                        if (target != -1)
                        {       /* Make sure texturing is disabled */
                                if (prd->ChequerMat[0].pTexture)
                                drawPiece(bd3d->pieceList, bd3d, (unsigned 
int)target, Abs(bd->points[target]) + 1, TRUE);
                glPolygonMode(GL_FRONT, GL_FILL);

and that printf statement is never called in my build.  So something is
either failing to set DragTargetHelp or iTargetHelpPoints or drawPieces is
never called while a move is in progress.  This seems to apply with either
quick-draw turned off or turned on.

I don't understand why I would be the only one seeing this, though.

Target help works fine with a 2D board.

I tried to use gdb to figure out why those variables aren't being set, but
it's very difficult to use gdb with gnubg and not have it lock up the X
server when one is trying to do it all on the same system.

Russ Allbery (address@hidden)             <http://www.eyrie.org/~eagle/>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]