[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug #35580] bootstrap is not portable to OpenBSD

From: Pádraig Brady
Subject: Re: [bug #35580] bootstrap is not portable to OpenBSD
Date: Fri, 09 Aug 2013 16:34:24 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130110 Thunderbird/17.0.2

On 08/09/2013 01:55 PM, Mike Miller wrote:
> On Fri, Aug 09, 2013 at 04:52:40AM +0100, Pádraig Brady wrote:
>> On 08/09/2013 03:23 AM, Mike Miller wrote:
>>> Thanks for the suggestion. I did try SHA1SUM=sha1, but that still
>>> won't work with bootstrap since find_tool() requires that $tool
>>> understand the --version option. That was mentioned earlier in the
>>> bug
>>> report linked above.
>> Oh that's a bit of a buglet then, as --version isn't required
>> unless a version is specified in the requirements.
>> Does SHA1SUM=sha1 work after applying...
>> commit 2c519cd635d46d314cd991b1a011464f7345c5fa
>> [...]
> Yes, that works perfectly. Of course, the code that uses sha1sum isn't
> being exercised on my project. I ran it against bison instead and it
> looks like it works now with sha1.
> Another fix might be to move "find_tool SHA1SUM" into the narrow case
> where it's actually used. It is not required unless a project has a po
> directory.

Excellent. I intend to push the attached change to bootstrap so,
that includes sha1 in the list now it's compatible, so therefore
not requiring one to set SHA1SUM on BSD at all.

Also I've implemented the optimization not to look for sha1sum
at all, when not updating po files.


Attachment: bootstrap-sha1.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]