[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NSTextField problems

From: Serg Stoyan
Subject: Re: NSTextField problems
Date: Tue, 28 Jan 2003 07:47:07 +0200

Hello Alexander,

 AM> Serg Stoyan wrote:
 AM> [snip]
 AM> > I'd like to add more:
 AM> > 
 AM> > 1) Exception:
 AM> > - type into textfield something;
 AM> > - switch to another textfield (for example);
 AM> > - return back clicking on it;
 AM> > - after typing just one character:
 AM> > Uncaught exception NSRangeException, reason:
glyphRangeForCharacterRange:actualCharacterRange:] character range out of
 AM> I've been unable to reproduce this, but I suspect that
 AM> -glyphIndexForPoint:... and NSTextView are disagreeing about what the
 AM> return value should be. I'll have a closer look at it to see if I can
 AM> figure it out.

     I'll try to help you.

 AM> > 2) no insertion point visible (not implemented?). By the way text is
 AM> > visible while typing in NSTextView (Affiche, Ink) but no insertion
 AM> There's no insertion point at the moment. I'm working on parsing the
 AM> docs so I can figure out how to handle all cases (the existence of
 AM> public methods for this only makes it harder).
 AM> > 3) problems displaying non-latin text in NSTextView both from
 AM> > input and loading from file. It is displayed as =01>@:><?;5:B or
 AM> Using which backend?

x11 + xlib. I've tried art backend with unicode TTFs, and saw no cyrillic 
text at all (even in form described above). Just latin characters. Note 
that before new text system commit everything is worked just fine.

Serg Stoyan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]