[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnuzilla] Switching interface language in about:config crashed

From: David Englund/Hedlund
Subject: Re: [Bug-gnuzilla] Switching interface language in about:config crashed IceCat
Date: Sun, 22 Mar 2015 02:09:19 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.5.0

On 2015-03-21 23:33, Ivan Zaigralin wrote:
On 03/21/2015 02:52 PM, David Englund wrote:
1) Installing

2) Modified about:config by follow the instructions in
https://support.mozilla.org/en-US/questions/1018686 used to "switch
between different interface languages":
* `*intl.locale.matchO*S` was set to `*false*`
* `*general.useragent.locale*` was set to `*sv-SE*`, nothing I've added,
its there as I installed the language pack in step 1 above.
* Restart Firefox for the change to take effect.

This cause IceCat to pop-up endless of message boxes. I had no chance to
see any text in these boxes or select anything (pressing enter or
right-key enter) did not help.

Rebooting Trisquel 7.0 LTE out of stress of seeing nearly 100 pop-up
dialogs, did not help either. However, modifying
`user_pref("intl.locale.matchOS", false);` in
/.mozilla/icecat/t9roh80p.default/prefs.js made IceCat behave normal
again, no pop-ups at all.
I just have one dialog, one of those yellow xpi dealies, but indeed
icecat fails to start with sv-SE. Works fine with ru-RU (other one I tried)

Please file this bug to Firefox ESR if its not IceCat related. Or should
I install Firefox ESR and try to reproduce this bug?
If that's a firefox bug (it may well be), you could file it yourself
just as well, especially since you've found it. I tried to test it, but
can't even find a Svenska language pack for ESR 31.5.0. It looks like
Mozilla strongly suggests to use localized binaries instead, so may be
they simply don't care.

The Swedish language pack are located in http://ftp.gnu.org/gnu/gnuzilla/31.5.0-gnu2/langpacks/icecat-31.5.0.sv-SE.langpack.xpi (as previously mentioned).

Can you please install it and try to reproduce the bug as I did above Ivan?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]