[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Initramfs not loaded or passed to kernel in grub2 UEFI x86_64

Subject: Re: Initramfs not loaded or passed to kernel in grub2 UEFI x86_64
Date: Tue, 8 Jun 2010 20:28:24 +0530

Sorry for the late reply. I typed in grub2 (x86_64 uefi) shell
(normal, sh mode) :-

linux (hd0,gpt8)/vmlinuz26 root=/dev/sda7 rootfstype=ext4 ro nomodeset debug=all

[Linux-bzImage, setup=0x3200, size=0x1f9180]

initrd (hd0,gpt8)/kernel26.img

[initrd, addr=0x3fd83000, size=0x27c853]


Again the same "VFS cannot open root device "sda7" " and "append
correct root= option" errors. 1 extra info I forgot to add before,
during kernel panic, CAPS LOCK was blinking but the keyboard and
touchpad were unresponsive. The initramfs is a lzma compressed cpio
archive created using mkinitcpio script of Archlinux.

I guess that the loaded initramfs's memory address and size passed by
grub2 uefi to the Archlinux kernel is wrong. Something wrong in
(grub2-source-dir)/loader/i386/efi/linux.c ? Is there a x86_64 uefi
specific linux.c file or is this the file for grub2 x86_64 uefi initrd

I tried booting Fedora 12 x86_64 kernel and Archlinux's initramfs, it
booted successfully. But dmesg output showed

Trying to unpack rootfs image as initramfs...
rootfs image is not initramfs (junk in compressed archive); looks like an initrd

I am attaching the entire dmesg output. I also tried booting Archlinux
using Fedora's grub-legacy fork whick includes efi and gpt support
and http://koji.fedoraproject.org/koji/buildinfo?buildID=161036). Its
grub.efi booted Archlinux successfully. I am attaching its
Archlinux+grub-legacy-efi dmesg output also.

2010/6/2 Vladimir 'φ-coder/phcoder' Serbinenko <address@hidden>:
> Can you try executing these commands one-by-one to capture an eventual
> error?
> --
> Regards
> Vladimir 'φ-coder/phcoder' Serbinenko

Attachment: dmesg_archlinux_grub-legacy-fedora_uefi_x64.txt
Description: Text document

Attachment: dmesg_fedora_kernel_grub2_efi_x64.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]