[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#36811: Guix fails to build with libgc 8.0.4

From: Ludovic Courtès
Subject: bug#36811: Guix fails to build with libgc 8.0.4
Date: Wed, 20 Nov 2019 16:39:16 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)

Jonathan Brielmaier <address@hidden> skribis:

> On 20.11.19 15:09, Ludovic Courtès wrote:
>> Hi Jonathan,
>> Jonathan Brielmaier <address@hidden> skribis:
>>> This failed with the same result:
>>> /gnu/store/29jhbbg1hf557x8j53f9sxd9imlmf02a-bash-minimal-5.0.7/bin/bash:
>>> line 7: 25584 Aborted                 (core dumped)
>>> XDG_CACHE_HOME=/nowhere host=x86_64-unknown-linux-gnu srcdir="."
>>> ./pre-inst-env
>>> /gnu/store/xrcl2csd0ps5n0zwj8r7knkxjnz4pfbh-guile-2.2.6/bin/guile -L "."
>>> -L "." --no-auto-compile -s "."/build-aux/compile-all.scm [*.scm]
>> So you built Guile (through Guix) against libgc 8.0.4, and then you
>> tried to use that Guile to build Guix, is that correct?
> Yes, that's what I did. So the problem really is with Guile not
> supporting libgc 8.0.4...

I think so, yes.

Can you post your patch to the libgc package, though?  It’s weird that
Guile passed its test suite but then crashes when compiling Guix.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]