[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20497: GuixSD installation - Build of system.drv failed

From: Ludovic Courtès
Subject: bug#20497: GuixSD installation - Build of system.drv failed
Date: Mon, 04 May 2015 23:48:32 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)


Jeffrey Serio <address@hidden> skribis:

>       "I've attempted installing GuixSD a few times on the same PC (Different 
> USBs, re-downloaded the image, etc.) 
>       and always get the same error-- that the build of system.drv failed. 
> I'm not exactly sure where to go from 
>       this error message, though, and I was wondering if someone did... 
> http://pastebin.com/3vG5GE4f";

The log at pastebin.com reads:

  55. builder for 'gnu/store/[... long string of characters 
...]-libarchive-3.1.2.drv' failed with exit code 1
  62. cannot build derivation '/gnu/store/[... long string ...]-system.drv': 1 
dependencies couldn't be built

This means that, to build the system configuration, Guix tried to build
libarchive, which failed.

It also means that somehow hydra.gnu.org was not providing pre-built
binaries for libarchive & co., perhaps because they have been GC’d.

What GuixSD version is it?

Thanks for your report!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]