[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20497: GuixSD installation - Build of system.drv failed

From: Jeffrey Serio
Subject: bug#20497: GuixSD installation - Build of system.drv failed
Date: Mon, 4 May 2015 19:57:43 -0500
User-agent: Mutt/1.5.23 (2014-03-12)


Thank you for your reply.  The GuixSD version is 0.8.1.  I figured part of the 
problem was with libarchive not 
being the pre-built binary.  I even tried reassuring that hydra was authorized, 
which apparently had no effect 
on the outcome.  Also, while using Guix as a package manager on my host system 
(Fedora 21), I attempted to 
install the package 'dfc' from source (not binary) and I encountered the 
libarchive-3.1.2.drv error there as well, so I checked the build log located at 
/tmp/nix-build*-libarchive-3.1.2.drv/.../test_option_b.log, and it mentioned 
that "File archive1.tar has size 
3072, expected 2048" and that "bsdtar does not pad archives written directly to 
regular files".  I hope this 
information helps narrow down the issue.  Do you have any suggestions as to how 
this could be resolved?

Best Regards,

On Mon, May 04, 2015 at 11:48:32PM +0200, Ludovic Courtès wrote:
> Hi,
> Jeffrey Serio <address@hidden> skribis:
> >     "I've attempted installing GuixSD a few times on the same PC (Different 
> > USBs, re-downloaded the image, etc.) 
> >     and always get the same error-- that the build of system.drv failed. 
> > I'm not exactly sure where to go from 
> >     this error message, though, and I was wondering if someone did... 
> > http://pastebin.com/3vG5GE4f";
> The log at pastebin.com reads:
>   55. builder for 'gnu/store/[... long string of characters 
> ...]-libarchive-3.1.2.drv' failed with exit code 1
>   [...]
>   62. cannot build derivation '/gnu/store/[... long string ...]-system.drv': 
> 1 dependencies couldn't be built
> This means that, to build the system configuration, Guix tried to build
> libarchive, which failed.
> It also means that somehow hydra.gnu.org was not providing pre-built
> binaries for libarchive & co., perhaps because they have been GC’d.
> What GuixSD version is it?
> Thanks for your report!
> Ludo’.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]