[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#24670: Unexpected EOF reading a line (from guix pull) [forward]

From: Ricardo Wurmus
Subject: bug#24670: Unexpected EOF reading a line (from guix pull) [forward]
Date: Thu, 13 Oct 2016 13:25:34 +0200
User-agent: mu4e 0.9.16; emacs 25.1.1

> address@hidden writes:
>> I'm just sending this to you since I think I might have figured out what is
>> happening, and I don't know how to respond to bugs via the mailing list.
>> Instruction on replying to bugs via the mailing list would be quite a help.
>> Basically, /var/lib/guix/profiles/per-user/$USER/guix-profile doesn't exist. 
>> For
>> example, on the root account on my machine (I've run guix pull multiple 
>> times as
>> root, and even tried to install icecat as a normal user, plus running guix 
>> pull
>> several times as a normal user) $HOME/.guix-profile points to a nonexistent
>> file/directory, and where it points to
>> (/var/lib/guix/profiles/per-user/root/guix-profile) simply doesn't
>> exist.

The profile is created automatically the first time “guix package -i” is
run.  This happens reliably for me on Fedora, CentOS, and on GuixSD.  If
this doesn’t happen Gentoo I suspect the Gentoo package to be defective
(e.g. setting invalid permissions on certain directories).

>> I've
>> even tried to track down where a profile might exist within /gnu/store, but
>> "ls /gnu/store/*profile*" responds with:

This is not important.  Anything Guix creates will be in the store.
This includes all profile generations.

I suggest installing Guix using the official binary package.  See this
page for the tarballs and the install instructions:


~~ Ricardo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]