[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#43035: gpg-agent can't find pinentry with linux-libre-5.8.3

From: Efraim Flashner
Subject: bug#43035: gpg-agent can't find pinentry with linux-libre-5.8.3
Date: Tue, 25 Aug 2020 12:45:45 +0300

This bug report sounds absurd to me but I don't see anything else
obvious that changed. I reconfigured with (kernel linux-libre) and the
gpg-agent couldn't find any pinentry. I even tried killing gpg-agent and
manually launching it and giving it the path to pinentry. I then changed
to (kernel linux-libre-5.7) and used the same commit to reconfigure and
gpg-agent started working as expected again.

I added and removed the qemu-binfmt-service-type before the first
failure with 5.8 and after 5.7 worked. I've attached my os config, and
here's a link¹ to the repo.

(ins)efraim@E5400 ~$ guix describe
Generation 58   Aug 24 2020 23:35:45    (current)
  guix c88bccc
    repository URL: https://git.savannah.gnu.org/git/guix.git
    commit: c88bccc14e29fceb0ac2b139cb5c73546bcee352


Efraim Flashner   <efraim@flashner.co.il>   אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

Attachment: E5400_config.scm
Description: Text document

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]