[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

uid_t vs. gid_t (was: The Hurdish Package Manager)

From: olafBuddenhagen
Subject: uid_t vs. gid_t (was: The Hurdish Package Manager)
Date: Sat, 10 Apr 2010 12:09:14 +0200
User-agent: Mutt/1.5.19 (2009-01-05)


On Fri, Apr 09, 2010 at 11:42:25AM +0200, Patrik Olsson wrote:

> I have found one thing that seems incorrect in
> hurd.git/hurd/password.defs. See the parameter/field "group" in
> "password_check_group"? Shouldn't it be of type gid_t and not uid_t?

Yeah, gid_t would definitely be clearer -- though technically they are
the same...

Note that in many places, an idarray_t is used instead of a single uid_t
or gid_t; which is *always* defined to uid_t.

gid_t in fact is used only in a single place so far...

Still, this probably should be fixed. How about a patch? :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]