[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

How to enable a SCSI CD-ROM ?

From: Thomas Schmitt
Subject: How to enable a SCSI CD-ROM ?
Date: Thu, 15 Sep 2011 11:35:07 +0200


can anybody remember to have used a SCSI CD-ROM with Hurd ?

I tried to get access to a virtual one created with kvm:
  -drive file=/dvdbuffer/netinst.iso,if=scsi,bus=4,unit=0,media=cdrom
but after booting Hurd, there is no /dev/sr0.

gnumach/linux/src/include/linux/major.h has
  #define SCSI_CDROM_MAJOR 11
So i did
  mknod /dev/sr0 b 11 0
and rebooted.

Something is still missing, though:
  $ su
  # dd if=/dev/sr0 bs=2048 skip=16 count=1 | strings
  dd: opening `/dev/sr0': Permission denied
  # ls -l /dev/sr0
  brw-rw-rw- 1 root root 11, 0 Sep 15 08:16 /dev/sr0
I get the same error message if i try to read from /dev/sr0 when no
SCSI CD-ROM is emulated.

An emulated IDE/ATAPI CD-ROM behaves quite as expected
  # dd if=/dev/hd2 bs=2048 skip=16 count=1 | strings | grep CD001
  1+0 records in
  1+0 records out
  2048 bytes (2.0 kB) copied, 0 s, Infinity B/s

kvm's SCSI CD-ROM emulation works with a RIP Linux rescue image.
RIP does not come up with -boot d from the emulated SCSI CD-ROM,
but if i submit RIPLinux-9.3-non-X.iso by -cdrom and the Hurd
netinst.iso by above -drive option, then i get a /dev/sr0 from
which i can read the PVD of Debian GNU/Hurd netinst.iso. 
(RIP's own ISO image appears as /dev/hdc.)

Have a nice day :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]