[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 1.5.54 make install failed

From: Mats Bengtsson
Subject: Re: 1.5.54 make install failed
Date: Wed, 24 Apr 2002 20:13:44 +0200

Hmm, my patches to try to fix problems haven't been too successful 
What I did was to use the 1.5.2 implementation of the 're' package 
even for newer versions of Python. This solved the problems that
were reported some week ago if you used Python 1.6-2.1.
Apparently, it caused some other problems instead, if you have
Python version 2.2.

Could you please try the attached patch. Unfortunately, I'm
unable to try it out here. I tried to install Python 2.2 
quickly on my machine but keep getting an error message about 
a missing module 'operator'. I'm not sure how this Python 
installation was built (I just copied it from another machine
where I don't have access to Lilypond) so it may be a problem 
of my installation.

Also, could someone please verify that it still solves the 
bug reported in 
if you have Python 2.2. I'm afraid it won't.


>               Everything is in the title...
>       Here is the output :
> Reading `/sources/lilypond/lilypond-1.5.54/mf/out/feta16list.ly'
> Traceback (most recent call last):
>    File "../.././scripts/lilypond-book.py", line 1396, in ?
>      do_file(input_filename)
>    File "../.././scripts/lilypond-book.py", line 1310, in do_file
>      chunks = process_lilypond_blocks(my_outname, chunks)
>    File "../.././scripts/lilypond-book.py", line 1004, in 
> process_lilypond_blocks
>      c = schedule_lilypond_block (c)
>    File "../.././scripts/lilypond-book.py", line 983, in 
> schedule_lilypond_block
>      newbody = output_verbatim (body)
>    File "../.././scripts/lilypond-book.py", line 481, in output_verbatim
>      body = re.sub ('(address@hidden)', '@\\1', body)
>    File "/usr/lib/python2.2/pre.py", line 179, in sub
>      return pattern.sub(repl, string, count)
>    File "/usr/lib/python2.2/pre.py", line 344, in sub
>      return self.subn(repl, string, count)[0]
>    File "/usr/lib/python2.2/pre.py", line 366, in subn
>      repl = pcre_expand(_Dummy, repl)
> TypeError: 'NoneType' object is not callable
> make[2]: *** [out/lilypond.nexi] Erreur 1
> make[2]: Quitte le répertoire 
> `/sources/lilypond/lilypond-1.5.54/Documentation/user'
> make[1]: *** [install] Erreur 2
> make[1]: Quitte le répertoire 
> `/sources/lilypond/lilypond-1.5.54/Documentation'
> make: *** [install] Erreur 2
> I saw in older mail that you speak about CVS branch can we acces it ? 
> (untill there's a new developement realaese each 2-3 days, it's not 
> realy usefull, but if it can help for compilationtest on different 
> computers, I'm HERE (near the tower Eiffel :o))
>       nemo.
> -- 
> Olivier Guéry <address@hidden>
> _______________________________________________
> Bug-lilypond mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/bug-lilypond

Attachment: lilypond-1.5.54.mb1.diff
Description: lilypond-1.5.54.mb1.diff

reply via email to

[Prev in Thread] Current Thread [Next in Thread]