[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: source lilypond.profile failed 1.7.30 address@hidden

From: Jan Nieuwenhuizen
Subject: Re: Fwd: source lilypond.profile failed 1.7.30 address@hidden
Date: 04 Aug 2003 18:56:11 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

Olivier Guéryéry <address@hidden> writes:

> sorry for my bad english, you won't understand. When i run the command
> my terminal died ! It's not me killing him, it's a sucied :o)
> My shell is zsh 4.1.0-dev-7 (i686-pc-linux-gnu) (from gentoo stable
> ebuilt).

We understand.

> I tried the changes Han-Wen sugest.

>     invoked as ./lilypond-profile

Yes, that was it.

> That's all, but the TEXMF is on, and I can use lilypond.

Thanks, I've checked in a woraround for ZSH.  Near the top of
lilypond-profile is now:

    # workaround for ZSH posix $0-problem
    [ -n "$ZSH_NAME" ] && setopt nofunctionargzero

I'm not very happy about this, it turns out that ZSH has a documented
posix problem with $0 inside functions and when sourcing.


Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]