[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Lilypond 2.2.2 under Win98

From: mlawrie
Subject: Lilypond 2.2.2 under Win98
Date: Sun, 25 Jul 2004 17:10:01 +0200


I'm trying to run lilypond 2.2.2 on a Win98 PC, but it does funny things. 
I run cygwin that identifies itself as

$ uname -a
CYGWIN_98-4.10 hennops 1.5.10(0.116/4/2) 2004-05-25 22:07 i686 unknown
unknown Cygwin

and lilypond that identfies itself as 

$ lilypond -v
lilypond (GNU LilyPond) 2.2.2

My windows system identifies itself as "Microsoft Windows 98 4.10.2222 A" 
(from start / programs / accessories / system tools / system information).

When I run even the most trivial of .ly files by means of the file 
associations that are set up during the lilypond installation, the program
produces a popup window with "Python2" in the title bar, and text "This
program has performed an illegal operation and will be shut down. If the
problem persists, contact the program vendor". Fortunately, if I simply
close these windows each time, the correct output files are produced 
(.log, .midi, .dvi, .ps, .tex, .pdf).

However, on a WinXP system there are no such hiccups. Running the 
identical .ly file from a cygwin installationd done from the idential
release files goes perfectly smoothly. On the XP system, Cygwin identifies
itself as 

$ uname -a
CYGWIN_NT-5.1 weevil 1.5.10(0.116/4/2) 2004-05-25 22:07 i686 unknown 
unknown Cygwin

If, on the Win98 system, I run lilypond in verbose mode, like this ...

$lilypond --verbose a.ly

... then the first three illegal operations pop up immediately after each
of the "Opening pipe" messages as shown below:-

$ lilypond --verbose a.ly
lilypond (GNU LilyPond) 2.2.2
Opening pipe `/usr/bin/lilypond-bin --version '
Opening pipe `kpsexpand \$TEXMF'
Opening pipe `kpsewhich -expand-path=\$T1FONTS'

There is then a lot of text that is output to the cygwin window, and then
the fourth "illegal operation" window pops up immediately after this

Opening pipe `kpsewhich feta20.pfa'

Seems like lilypond is using a pipe technique that is not supported by
cygwin under Win98?

Is there something that you can do about this? Seems to me that the pipe
operations are not needed at all by lilypond, because the desired lilypond
output is still produced and it all looks good to me.

Mike Lawrie.
Ph +27 12 348 0944 or 072 480 8898

reply via email to

[Prev in Thread] Current Thread [Next in Thread]