[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fontmap entry for Fontmap.local ends prematurely!

From: James Lowe
Subject: Re: Fontmap entry for Fontmap.local ends prematurely!
Date: Sun, 6 Dec 2015 00:02:04 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.3.0

Hello Karl,

On 30/11/15 00:43, Karl Berry wrote:
> I installed lilypond from your lilypond-2.18.2-1.linux-x86.sh (from
> http://www.lilypond.org/unix.html) on centos 6.7.  Running lilypond -V --pdf
> test.ly with the test.ly file from that same page ends with:
> ----
> Converting to `./newtest.pdf'...
> -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite
> -sOutputFile=./newtest.pdf -c.setpdfwrite -fnewtest.ps'...
> GPL Ghostscript 8.70 (2009-07-31)
> Copyright (C) 2009 Artifex Software, Inc.  All rights reserved.
> This software comes with NO WARRANTY: see the file PUBLIC for details.
> Fontmap entry for Fontmap.local ends prematurely!  Giving up.
> -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite
> -sOutputFile=./newtest.pdf -c.setpdfwrite -fnewtest.ps)' failed (256)
> fatal error: failed files: "newtest.ly"
> ----
> The /etc/ghostscript/8.70/Fontmap.local on my system is just an empty file.
>  I suppose Lilypond is using some Fontmap.local of its own in its own gs's
> Resource/Init or whatever.
> When I run the stated gs command from the command line, explicitly using the
> lilypond-provided gs, it runs fine.  (it also runs fine with the
> system-provided gs, and the latest gs-9.18 release which I compiled myself.)
> No problem getting on with things, but I just thought I'd report that the
> stated first recipe failed.  If I can do anything useful for further
> debugging, just let me know.  

We have no plans for any more 2.18.x releases, so ca you confirm if you
still get the same problem when using the lastest development (2.19.x)
available download?




 ------- B8F4 5395 CBE2 ED37 7513 B075 FF32 5682 A84B D8BE

reply via email to

[Prev in Thread] Current Thread [Next in Thread]