[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: phantom
Subject: bug
Date: Sat, 20 Dec 2003 18:36:58 -0500
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031220

It seems like parted 1.6.3 do strange things...
I wanted to delete partition 5 6 7 8, I removed 8 7 6 5
then created a new partition
then formatted it
mounted it
mounted my old #9 (supposed to be 6)
wait, the old is not there!
what it did is:
removed 6 7 8 9
created partition 5
and swapped the old 5 for 6!

so my partition was 1 2 3 4 [ 6 5 ] (4 being extended)

This is the second time it happend, on 2 differents disk

It seems like fdisk + parted and deleting and creating some partitions make some mess somewhere and parted swap some partitions!

Before I removed the partition, I did a print, and verified if everything was right, everything was in order...

As I don't want to mess my system again (lost some stuff again) I didn't tried to reproduce this...

My first drive is a raid5 (Promise SuperTrack SX6000, hardware ata raid5 controler, 6 channels, seen as a scsi disk)
My second is a Cheetah X15 36 gig (15krpm scsi160)

I double verified before I removed the partitions, so I'm sure it's not a user error...

This is the now fixed print...
Disk geometry for /dev/scsi/host0/bus0/target0/lun0/disc: 0.000-35003.598 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    101.975  primary   ext2
2        101.975    203.950  primary   ext2        boot
3        203.950   1184.479  primary   linux-swap
4       1184.480  35000.991  extended              lba
5       1184.511  35000.991  logical   ext3

reply via email to

[Prev in Thread] Current Thread [Next in Thread]